use strict;
my $str = '你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
Test
Test
Иванов
S1f你好jd
S1f 你好jd
Yury-sd
Юрий-
-Юрий
фывфвы-фывфыв
Юрий выв
Фа фФвSsыв
фФвSsыв';
my $regex = qr/^(\p{sc=Han}+$|[а-яА-Я]+|[a-zA-Z]+)$/muip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}