$re = '/^(\p{sc=Han}+$|[а-яА-Я]+|[a-zA-Z]+)$/mui';
$str = '你妳好12312
第三方
阿伱斯顿АквsSукпП
阿斯Фа фФвSsыв
Yury1
Test
Test
Иванов
S1f你好jd
S1f 你好jd
Yury-sd
Юрий-
-Юрий
фывфвы-фывфыв
Юрий выв
Фа фФвSsыв
фФвSsыв';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);