# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(\p{sc=Han}+$|[а-яА-Я]+|[a-zA-Z]+)$"
test_str = ("你妳好12312\n"
"第三方\n"
"阿伱斯顿АквsSукпП\n"
"阿斯Фа фФвSsыв\n"
"Yury1\n"
"Test\n"
" Test\n"
"Иванов\n"
"S1f你好jd\n"
"S1f 你好jd\n"
"Yury-sd\n"
"Юрий-\n"
"-Юрий\n"
"фывфвы-фывфыв\n"
"Юрий выв\n"
"Фа фФвSsыв\n"
"фФвSsыв")
matches = re.finditer(regex, test_str, re.MULTILINE | re.UNICODE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.