#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^(?:(?:[a-z]:)[\/\\]{1,2}|[\/\\]?)(?:[.\/\\ ](?![.\/\\\n])|[^<>:"|?*.\/\\ \n\r\t\f\v])+(\/|\\)?$"
Local $sString = "C://test" & @CRLF & _
"C://te?st.html" & @CRLF & _
"C:/test" & @CRLF & _
"C://test.html" & @CRLF & _
"C://test/hello.html" & @CRLF & _
"C:/test/hello.html" & @CRLF & _
"//test" & @CRLF & _
":c:ok" & @CRLF & _
"/test/hello.txt" & @CRLF & _
"/test/hello.txt." & @CRLF & _
"/test//hello.txt" & @CRLF & _
"//test/hello.txt" & @CRLF & _
"//test.html" & @CRLF & _
"//10.1.1.107" & @CRLF & _
"//10.1.1.107/test.html" & @CRLF & _
"//10.1.1.107/test/hello.html" & @CRLF & _
"//10.1.1.107/test/hello" & @CRLF & _
"/test/html" & @CRLF & _
"/test|/html" & @CRLF & _
"/test&/html" & @CRLF & _
"/tes?t/html" & @CRLF & _
"C::\\test" & @CRLF & _
":\\test" & @CRLF & _
":\hello.html" & @CRLF & _
"/test.html" & @CRLF & _
"test.html" & @CRLF & _
"//" & @CRLF & _
"/" & @CRLF & _
"/?/" & @CRLF & _
"\\\\" & @CRLF & _
"\\" & @CRLF & _
"test/hello\ok.html" & @CRLF & _
" /test/hello.txt" & @CRLF & _
"/this/ends/with/a/space " & @CRLF & _
"" & @CRLF & _
" /test/hello.txt" & @CRLF & _
"/t!esrtr" & @CRLF & _
"C:/hel*o"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")