const regex = /^(?:(?:[a-z]:)[\/\\]{1,2}|[\/\\]?)(?:[.\/\\ ](?![.\/\\\n])|[^<>:"|?*.\/\\ \n\r\t\f\v])+(\/|\\)?$/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:[a-z]:)[\\\/\\\\]{1,2}|[\\\/\\\\]?)(?:[.\\\/\\\\ ](?![.\\\/\\\\\\n])|[^<>:"|?*.\\\/\\\\ \\n\\r\\t\\f\\v])+(\\\/|\\\\)?$', 'gmi')
const str = `C://test
C://te?st.html
C:/test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
:c:ok
/test/hello.txt
/test/hello.txt.
/test//hello.txt
//test/hello.txt
//test.html
//10.1.1.107
//10.1.1.107/test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
/test/html
/test|/html
/test&/html
/tes?t/html
C::\\\\test
:\\\\test
:\\hello.html
/test.html
test.html
//
/
/?/
\\\\\\\\
\\\\
test/hello\\ok.html
/test/hello.txt
/this/ends/with/a/space
/test/hello.txt
/t!esrtr
C:/hel*o`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}