re = /^(?:(?:[a-z]:)[\/\\]{1,2}|[\/\\]?)(?:[.\/\\ ](?![.\/\\\n])|[^<>:"|?*.\/\\ \n\r\t\f\v])+(\/|\\)?$/mi
str = 'C://test
C://te?st.html
C:/test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
:c:ok
/test/hello.txt
/test/hello.txt.
/test//hello.txt
//test/hello.txt
//test.html
//10.1.1.107
//10.1.1.107/test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
/test/html
/test|/html
/test&/html
/tes?t/html
C::\\\\test
:\\\\test
:\\hello.html
/test.html
test.html
//
/
/?/
\\\\\\\\
\\\\
test/hello\\ok.html
/test/hello.txt
/this/ends/with/a/space
/test/hello.txt
/t!esrtr
C:/hel*o'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end