import Foundation
let pattern = #"^(?:(?:[a-z]:)[\/\\]{1,2}|[\/\\]?)(?:[.\/\\ ](?![.\/\\\n])|[^<>:"|?*.\/\\ \n\r\t\f\v])+(\/|\\)?$"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
C://test
C://te?st.html
C:/test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
:c:ok
/test/hello.txt
/test/hello.txt.
/test//hello.txt
//test/hello.txt
//test.html
//10.1.1.107
//10.1.1.107/test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
/test/html
/test|/html
/test&/html
/tes?t/html
C::\\test
:\\test
:\hello.html
/test.html
test.html
//
/
/?/
\\\\
\\
test/hello\ok.html
/test/hello.txt
/this/ends/with/a/space
/test/hello.txt
/t!esrtr
C:/hel*o
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)