use strict;
my $str = 'C://test
C://te?st.html
C:/test
C://test.html
C://test/hello.html
C:/test/hello.html
//test
:c:ok
/test/hello.txt
/test/hello.txt.
/test//hello.txt
//test/hello.txt
//test.html
//10.1.1.107
//10.1.1.107/test.html
//10.1.1.107/test/hello.html
//10.1.1.107/test/hello
/test/html
/test|/html
/test&/html
/tes?t/html
C::\\\\test
:\\\\test
:\\hello.html
/test.html
test.html
//
/
/?/
\\\\\\\\
\\\\
test/hello\\ok.html
/test/hello.txt
/this/ends/with/a/space
/test/hello.txt
/t!esrtr
C:/hel*o';
my $regex = qr/^(?:(?:[a-z]:)[\/\\]{1,2}|[\/\\]?)(?:[.\/\\ ](?![.\/\\\n])|[^<>:"|?*.\/\\ \n\r\t\f\v])+(\/|\\)?$/mip;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}