package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).{2}`)
var str = `596d396962334a76`
var substitution = "\\x$&"
fmt.Println(re.ReplaceAllString(str, substitution))
}