use strict;
my $str = '596d396962334a76';
my $regex = qr/.{2}/mp;
my $subst = '\\\\x$&';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";