import re
regex = re.compile(r".{2}", flags=re.MULTILINE)
test_str = "596d396962334a76"
subst = "\\\\x$&"
result = regex.sub(subst, test_str)
if result:
print(result)