import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:^(?<host>[\\w\\-]+\\.[\\w\\-.]*?)\\.\\s*(?<ttl>\\d+)\\s*(?<wtf>\\w*)\\s*(?<rectype>\\w*)\\s*(?<value>.*)\\s*$)";
final String string = "_ec39e6bc8bebcabc317adda693b733ad.jantje.nl. 300 IN CNAME fb3ba5c5340b42c955f7aac5afb84eea.f0c1a3a97d2c1a6bb1ffe20291574d08.8j8l2h4f.comodoca.com.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}