import Foundation
let pattern = #"(?:^(?<host>[\w\-]+\.[\w\-.]*?)\.\s*(?<ttl>\d+)\s*(?<wtf>\w*)\s*(?<rectype>\w*)\s*(?<value>.*)\s*$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"_ec39e6bc8bebcabc317adda693b733ad.jantje.nl. 300 IN CNAME fb3ba5c5340b42c955f7aac5afb84eea.f0c1a3a97d2c1a6bb1ffe20291574d08.8j8l2h4f.comodoca.com."#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}