# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:^(?<host>[\w\-]+\.[\w\-.]*?)\.\s*(?<ttl>\d+)\s*(?<wtf>\w*)\s*(?<rectype>\w*)\s*(?<value>.*)\s*$)
"""
test_str = "_ec39e6bc8bebcabc317adda693b733ad.jantje.nl. 300 IN CNAME fb3ba5c5340b42c955f7aac5afb84eea.f0c1a3a97d2c1a6bb1ffe20291574d08.8j8l2h4f.comodoca.com."
matches = re.search(regex, test_str, re.MULTILINE | re.VERBOSE)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.