$re = '/(?:^(?<host>[\w\-]+\.[\w\-.]*?)\.\s*(?<ttl>\d+)\s*(?<wtf>\w*)\s*(?<rectype>\w*)\s*(?<value>.*)\s*$)/mx';
$str = '_ec39e6bc8bebcabc317adda693b733ad.jantje.nl. 300 IN CNAME fb3ba5c5340b42c955f7aac5afb84eea.f0c1a3a97d2c1a6bb1ffe20291574d08.8j8l2h4f.comodoca.com.';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);