const regex = /(?:^(?<host>[\w\-]+\.[\w\-.]*?)\.\s*(?<ttl>\d+)\s*(?<wtf>\w*)\s*(?<rectype>\w*)\s*(?<value>.*)\s*$)/m;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:^(?<host>[\\w\\-]+\\.[\\w\\-.]*?)\\.\\s*(?<ttl>\\d+)\\s*(?<wtf>\\w*)\\s*(?<rectype>\\w*)\\s*(?<value>.*)\\s*$)', 'm')
const str = `_ec39e6bc8bebcabc317adda693b733ad.jantje.nl. 300 IN CNAME fb3ba5c5340b42c955f7aac5afb84eea.f0c1a3a97d2c1a6bb1ffe20291574d08.8j8l2h4f.comodoca.com.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}