const regex = /^(.*)\n(.*\n)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*)\\n(.*\\n)', 'gm')
const str = `LINE1
LINE2
LINE3
LINE4
LINE5
LINE6
`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);