import re
regex = re.compile(r"^(.*)\n(.*\n)", flags=re.MULTILINE)
test_str = ("LINE1\n"
"LINE2\n"
"LINE3\n"
"LINE4\n"
"LINE5\n"
"LINE6\n")
subst = "$1$2"
result = regex.sub(subst, test_str)
if result:
print(result)