use strict;
my $str = 'LINE1
LINE2
LINE3
LINE4
LINE5
LINE6
';
my $regex = qr/^(.*)\n(.*\n)/mp;
my $subst = '$1$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";