#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)请前往(?<address>.*?(?:小区|路))(?<name>.*?)领取快递包裹"
Local $sString = "请前往某某小区12幢一楼某某驿站领取快递包裹" & @CRLF & _
"请前往某某路152号(某某小区东门左转)某某快递点领取快递包裹"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")