const regex = /请前往(?<address>.*?(?:小区|路))(?<name>.*?)领取快递包裹/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('请前往(?<address>.*?(?:小区|路))(?<name>.*?)领取快递包裹', 'gm')
const str = `请前往某某小区12幢一楼某某驿站领取快递包裹
请前往某某路152号(某某小区东门左转)某某快递点领取快递包裹`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}