import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "请前往(?<address>.*?(?:小区|路))(?<name>.*?)领取快递包裹";
final String string = "请前往某某小区12幢一楼某某驿站领取快递包裹\n"
+ "请前往某某路152号(某某小区东门左转)某某快递点领取快递包裹";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}