package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)请前往(?<address>.*?(?:小区|路))(?<name>.*?)领取快递包裹`)
var str = `请前往某某小区12幢一楼某某驿站领取快递包裹
请前往某某路152号(某某小区东门左转)某某快递点领取快递包裹`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}