$re = '/请前往(?<address>.*?(?:小区|路))(?<name>.*?)领取快递包裹/m';
$str = '请前往某某小区12幢一楼某某驿站领取快递包裹
请前往某某路152号(某某小区东门左转)某某快递点领取快递包裹';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);