#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?=.*[~!@#$%^&*()_+`\-=\[\]\{\};':\",./<>?])(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])\S{6,}$"
Local $sString = "abcdef" & @CRLF & _
"ABCDEFG" & @CRLF & _
"123456" & @CRLF & _
"!@#$%^" & @CRLF & _
"abc123" & @CRLF & _
"Abc123" & @CRLF & _
"adfasdf Abc123! dafdsfsf" & @CRLF & _
"Abc123'" & @CRLF & _
"Abc$123" & @CRLF & _
"Abc 123" & @CRLF & _
"Aaaa$12" & @CRLF & _
"aaaA$12" & @CRLF & _
"$12aaaA"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")