use strict;
my $str = 'abcdef
ABCDEFG
123456
!@#$%^
abc123
Abc123
adfasdf Abc123! dafdsfsf
Abc123\'
Abc$123
Abc 123
Aaaa$12
aaaA$12
$12aaaA';
my $regex = qr/^(?=.*[~!@#$%^&*()_+`\-=\[\]\{\};':\",./<>?])(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])\S{6,}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}