import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.*[~!@#$%^&*()_+`\\-=\\[\\]\\{\\};':\\\",./<>?])(?=.*[0-9])(?=.*[a-z])(?=.*[A-Z])\\S{6,}$";
final String string = "abcdef\n"
+ "ABCDEFG\n"
+ "123456\n"
+ "!@#$%^\n"
+ "abc123\n"
+ "Abc123\n"
+ "adfasdf Abc123! dafdsfsf\n"
+ "Abc123'\n"
+ "Abc$123\n"
+ "Abc 123\n"
+ "Aaaa$12\n"
+ "aaaA$12\n"
+ "$12aaaA";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}