using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"iPhone; CPU ([^)]+) like Mac OS";
string input = @"(iPhone; CPU iPhone OS 16_3 like Mac OS X";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}