// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)iPhone; CPU ([^)]+) like Mac OS").unwrap();
let string = "(iPhone; CPU iPhone OS 16_3 like Mac OS X";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}