package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)iPhone; CPU ([^)]+) like Mac OS`)
var str = `(iPhone; CPU iPhone OS 16_3 like Mac OS X`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}