$re = '/iPhone; CPU ([^)]+) like Mac OS/i';
$str = '(iPhone; CPU iPhone OS 16_3 like Mac OS X';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);