using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\/endpoint\/\d+,\d+(?:,\d+)*$";
string input = @"/endpoint/142,15
/endpoint/142,15,415
/endpoint/142
/endpoint/142,15,985
/endpoint/1,2,3,4
/endpoint/9999,9928,2918,2984,298174
/endpoint/
/endpoint/32,a
/endpoint/1,2,3,4,test
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}