import Foundation
let pattern = #"^\/endpoint\/\d+,\d+(?:,\d+)*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
/endpoint/142,15
/endpoint/142,15,415
/endpoint/142
/endpoint/142,15,985
/endpoint/1,2,3,4
/endpoint/9999,9928,2918,2984,298174
/endpoint/
/endpoint/32,a
/endpoint/1,2,3,4,test
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)