use strict;
my $str = '/endpoint/142,15
/endpoint/142,15,415
/endpoint/142
/endpoint/142,15,985
/endpoint/1,2,3,4
/endpoint/9999,9928,2918,2984,298174
/endpoint/
/endpoint/32,a
/endpoint/1,2,3,4,test
';
my $regex = qr/^\/endpoint\/\d+,\d+(?:,\d+)*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}