import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "#region(?> |\\t)*(?'name'.*)$(?'content'(.|\\n)*?)#endregion";
final String string = "using System;\n"
+ "using System.Collections.Generic;\n"
+ "using System.Linq;\n"
+ "using System.Text;\n"
+ "using System.Threading.Tasks;\n"
+ "using System.Reflection;\n"
+ "using Autodesk.Revit.UI;\n"
+ "using Autodesk.Revit;\n\n"
+ "namespace RevitAPIExtension.Resources\n"
+ "{\n"
+ " class AddinsPanel\n"
+ " {\n"
+ " public static void Build(UIControlledApplication application, string tabName)\n"
+ " {\n"
+ " string assemblyPath = Assembly.GetExecutingAssembly().Location;\n"
+ " RibbonPanel panel = application.GetRibbonPanels()\n"
+ " .FirstOrDefault(p => p.Name.Equals(\"addinPanel\", StringComparison.InvariantCulture));\n"
+ " panel = panel ?? application.CreateRibbonPanel(\"addinPanel\");\n"
+ " #region PushButtons\n"
+ " #endregion\n"
+ " }\n"
+ " }\n"
+ "}\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}