import re
regex = re.compile(r"#region(?> |\t)*(?'name'.*)$(?'content'(.|\n)*?)#endregion", flags=re.MULTILINE)
test_str = ("using System;\n"
"using System.Collections.Generic;\n"
"using System.Linq;\n"
"using System.Text;\n"
"using System.Threading.Tasks;\n"
"using System.Reflection;\n"
"using Autodesk.Revit.UI;\n"
"using Autodesk.Revit;\n\n"
"namespace RevitAPIExtension.Resources\n"
"{\n"
" class AddinsPanel\n"
" {\n"
" public static void Build(UIControlledApplication application, string tabName)\n"
" {\n"
" string assemblyPath = Assembly.GetExecutingAssembly().Location;\n"
" RibbonPanel panel = application.GetRibbonPanels()\n"
" .FirstOrDefault(p => p.Name.Equals(\"addinPanel\", StringComparison.InvariantCulture));\n"
" panel = panel ?? application.CreateRibbonPanel(\"addinPanel\");\n"
" #region PushButtons\n"
" #endregion\n"
" }\n"
" }\n"
"}\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")