$re = '/#region(?> |\t)*(?\'name\'.*)$(?\'content\'(.|\n)*?)#endregion/m';
$str = 'using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Reflection;
using Autodesk.Revit.UI;
using Autodesk.Revit;
namespace RevitAPIExtension.Resources
{
class AddinsPanel
{
public static void Build(UIControlledApplication application, string tabName)
{
string assemblyPath = Assembly.GetExecutingAssembly().Location;
RibbonPanel panel = application.GetRibbonPanels()
.FirstOrDefault(p => p.Name.Equals("addinPanel", StringComparison.InvariantCulture));
panel = panel ?? application.CreateRibbonPanel("addinPanel");
#region PushButtons
#endregion
}
}
}
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);