import Foundation
let pattern = ##"#region(?> |\t)*(?'name'.*)$(?'content'(.|\n)*?)#endregion"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Reflection;
using Autodesk.Revit.UI;
using Autodesk.Revit;
namespace RevitAPIExtension.Resources
{
class AddinsPanel
{
public static void Build(UIControlledApplication application, string tabName)
{
string assemblyPath = Assembly.GetExecutingAssembly().Location;
RibbonPanel panel = application.GetRibbonPanels()
.FirstOrDefault(p => p.Name.Equals("addinPanel", StringComparison.InvariantCulture));
panel = panel ?? application.CreateRibbonPanel("addinPanel");
#region PushButtons
#endregion
}
}
}
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)