const regex = /#region(?> |\t)*(?'name'.*)$(?'content'(.|\n)*?)#endregion/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('#region(?> |\\t)*(?\'name\'.*)$(?\'content\'(.|\\n)*?)#endregion', 'gm')
const str = `using System;
using System.Collections.Generic;
using System.Linq;
using System.Text;
using System.Threading.Tasks;
using System.Reflection;
using Autodesk.Revit.UI;
using Autodesk.Revit;
namespace RevitAPIExtension.Resources
{
class AddinsPanel
{
public static void Build(UIControlledApplication application, string tabName)
{
string assemblyPath = Assembly.GetExecutingAssembly().Location;
RibbonPanel panel = application.GetRibbonPanels()
.FirstOrDefault(p => p.Name.Equals("addinPanel", StringComparison.InvariantCulture));
panel = panel ?? application.CreateRibbonPanel("addinPanel");
#region PushButtons
#endregion
}
}
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}