#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)mark"
Local $sString = "I went to the market so I was marketing." & @CRLF & _
"But it was unremarkable..." & @CRLF & _
"" & @CRLF & _
"I stored my results in the filepath:" & @CRLF & _
"/home/adyork/marketsurvey/leftmymark.csv" & @CRLF & _
"" & @CRLF & _
"mark" & @CRLF & _
"marketing" & @CRLF & _
"unremarkable"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")