re = /mark/m
str = 'I went to the market so I was marketing.
But it was unremarkable...
I stored my results in the filepath:
/home/adyork/marketsurvey/leftmymark.csv
mark
marketing
unremarkable'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end