import re
regex = re.compile(r"mark", flags=re.MULTILINE)
test_str = ("I went to the market so I was marketing.\n"
"But it was unremarkable...\n\n"
"I stored my results in the filepath:\n"
"/home/adyork/marketsurvey/leftmymark.csv\n\n"
"mark\n"
"marketing\n"
"unremarkable")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")