# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:^
(?:
\( [^)]* \)
|
\p{Lu}+ (?>[ ]\p{Lu}+\b)*
(?>\/\p{Lu}+(?>[ ]\p{Lu}+ \b)* )*
)
[ ]
)?
[^\/\n]*+ \K ./ or /gmxu;t' <<< "Dogs/Cats/Mice
ANIMALS/SPECIES Dogs/Cats/Mice
(Animals/Species) Dogs/Cats/Mice
ANIMALS/SPECIES Dogs and Cats/Mice
BRITISH RECIPES/DESSERT pudding/rum baba/crumble
RECIPES/BRITISH DESSERT pudding/crumble"