$re = '~(?:^
(?:
\( [^)]* \)
|
\p{Lu}+ (?>[ ]\p{Lu}+\b)*
(?>/\p{Lu}+(?>[ ]\p{Lu}+ \b)* )*
)
[ ]
)?
[^/\n]*+ \K .~mxu';
$str = 'Dogs/Cats/Mice
ANIMALS/SPECIES Dogs/Cats/Mice
(Animals/Species) Dogs/Cats/Mice
ANIMALS/SPECIES Dogs and Cats/Mice
BRITISH RECIPES/DESSERT pudding/rum baba/crumble
RECIPES/BRITISH DESSERT pudding/crumble';
$subst = " or ";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;