use strict;
my $str = 'Dogs/Cats/Mice
ANIMALS/SPECIES Dogs/Cats/Mice
(Animals/Species) Dogs/Cats/Mice
ANIMALS/SPECIES Dogs and Cats/Mice
BRITISH RECIPES/DESSERT pudding/rum baba/crumble
RECIPES/BRITISH DESSERT pudding/crumble';
my $regex = qr~(?:^
(?:
\( [^)]* \)
|
\p{Lu}+ (?>[ ]\p{Lu}+\b)*
(?>/\p{Lu}+(?>[ ]\p{Lu}+ \b)* )*
)
[ ]
)?
[^/\n]*+ \K .~mxup;
my $subst = ' or ';
my $result = $str =~ s~$regex~$subst~rg;
print "The result of the substitution is' $result\n";