package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:^
(?:
\( [^)]* \)
|
\p{Lu}+ (?>[ ]\p{Lu}+\b)*
(?>/\p{Lu}+(?>[ ]\p{Lu}+ \b)* )*
)
[ ]
)?
[^/\n]*+ \K .`)
var str = `Dogs/Cats/Mice
ANIMALS/SPECIES Dogs/Cats/Mice
(Animals/Species) Dogs/Cats/Mice
ANIMALS/SPECIES Dogs and Cats/Mice
BRITISH RECIPES/DESSERT pudding/rum baba/crumble
RECIPES/BRITISH DESSERT pudding/crumble`
var substitution = " or "
fmt.Println(re.ReplaceAllString(str, substitution))
}