# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
(?:^
(?:
\( [^)]* \)
|
\p{Lu}+ (?>[ ]\p{Lu}+\b)*
(?>/\p{Lu}+(?>[ ]\p{Lu}+ \b)* )*
)
[ ]
)?
[^/\n]*+ \K .
"""
test_str = ("Dogs/Cats/Mice\n"
"ANIMALS/SPECIES Dogs/Cats/Mice\n"
"(Animals/Species) Dogs/Cats/Mice\n"
"ANIMALS/SPECIES Dogs and Cats/Mice\n"
"BRITISH RECIPES/DESSERT pudding/rum baba/crumble\n"
"RECIPES/BRITISH DESSERT pudding/crumble")
subst = " or "
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE | re.VERBOSE | re.UNICODE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.