using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((:(?!CID))|;)(.*)";
string input = @" 1. (s)[18014]:Recorded command information.
2. (l):User logged out.
3. (s)[18014]:CID=0x11aa2222;The user succeeded in logging out of XXX.";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}