import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "((:(?!CID))|;)(.*)";
final String string = " 1. (s)[18014]:Recorded command information.\n"
+ " 2. (l):User logged out.\n"
+ " 3. (s)[18014]:CID=0x11aa2222;The user succeeded in logging out of XXX.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}