re = /((:(?!CID))|;)(.*)/m
str = ' 1. (s)[18014]:Recorded command information.
2. (l):User logged out.
3. (s)[18014]:CID=0x11aa2222;The user succeeded in logging out of XXX.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end